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 Metrology Laboratory 
Department of Mechanical Engineering 

 

Experiment No. 5 

STUDY OF DCC-COORDINATE MEASURING MACHINE AND EXPLORING FEW 
DIMENSIONAL FEATURES OF AN ARTEFACT  

Aim: 

- To study the functions of different parts of CMM. 
- To study the conventions used for Machine Coordinate System and Workpiece 

Coordinate System. 
- To calibrate the probe tip at three different angles. 
- To check different dimensional attributes like circularity, cylindricity, flatness, run 

out, etc and the corresponding tolerance values.  
 
 

Principle of measurement: 

 

                                   Fig 1 Co-ordinate Measuring Machine with its parts 
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It is used for geometrical feature measurement. The typical "bridge" CMM is composed of three 
axes, X, Y and Z. These axes are orthogonal to each other in a typical three dimensional coordinate 
system. Each axis has a scale system or encoder that indicates the translation of the axes. The 
machine will read the input points from the touch probe by touching the required location, as 
directed by the operator or programmer. The machine then uses the X,Y,Z coordinates of each of 
these points to determine size and position of the job. Then the measurands (e.g. length, diameter, 
angle, flatness, straightness etc.) can be determined by those points. A coordinate measuring machine 
(CMM) is also a device used in manufacturing and assembly processes to test a part or assembly 
against the design intent. By precisely recording the X, Y, and Z coordinates of the target, points are 
generated which can then be analyzed via regression algorithms for the construction of features. 
These points are collected by using a probe that is positioned manually by an operator or 
automatically via Direct Computer Control (DCC). DCC CMMs can be programmed to 
repeatedly measure identical parts; thus a CMM is a specialized form of industrial robot. In CMM 
there are mainly two major parts. There are structural system and probing system. Machine 
structure, bridge, bearings for moving the bridge, granit table to support the workpiece, vibration 
isolation system and are included in the structural systems.  Air bearings are the chosen method for 
ensuring friction free travel. Compressed air is forced through a series of very small holes in a flat 
bearing surface to provide a smooth but controlled air cushion on which the CMM can move in a 
frictionless manner. In probing system one touch trigger probe is attached to the Z-axis quill of the 
bridge.  

When probe is rotated about X-axis it is then called as angle A, and when the probe is rotated about 
Z-axis, then it is called as angle B. 

Tesastar-p is the probe used in this machine. This probe can rotate in two directions viz A & B 

A0B0:- Angle A=0, and Angle B=0 

                                                                     

              Fig 2a  A0B0 position of probe                               Fig 2b A90B90 position of probe 

When rotation of probe is in CCW manner w.r.t. axis of rotation than it is considered positive else 
negative. 

Range of angles: 

Angle A: Probe can rotate from +90 to -115 about X-axis. 

Angle B: Probe can rotate from +180 to -180 about Z- axis. 

Measuring Modes: Manual Mode and Automatic Mode . 
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Jobs to do: 

 

 

 

Fig 3  Job 1 (Artefact supplied by TESA) 

Job 1: Artefact supplied by TESA 

1. Define plane, line and origin in manual mode. 

2. Measure: 

   a. Inner diameter, circularity of the Bigger Hole 

   b. Height, cone angle and diameter of the Cone 

   c. Round slot 

   d. Measurement of all the holes in polar array in DCC mode 

   e. Sphere diameter 

Feature Dimension 1 2 3 Avg Value, 
mm 

Bigger Hole Inner diameter     
Circularity     

Cone 
Height     
Cone angle     
Diameter     

Round slot Radius     
Holes in polar array  Diameter     
Sphere Diameter     
 

 

 

 

Bigger Hole 

Holes in Polar array Round Slot 

Sphere Cone 
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Job 2: Spur Gear 

 

Fig 4 Job 2 (Spur Gear) 

  

 

 

 

 

 

 

 

 

 Dimension 1 2 3 Avg Value, 
mm 

Addendum circle diameter     
Root circle diameter     
Pitch     
 

Specifications of CMM and probe used: 

Sl 
No 

Items Specifications 

1 Bridge type CMM Measuring Volume: 400 mm x 700 mm x 
400 mm. 
TESA (Swiss Company): Model 4-7-4 
Resolution: 0.1 μm 

2 Qualification Sphere Motorized Probing System 
Material of probe tip: Ruby 
Diameter of probe tip: 1/2/4 mm 
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Report Should Contain: 

a. A neat sketch of CMM with proper mentioning of the machine and probe axes. 
b. Calibration procedure of probe tip at angles: A__B__, A__B__ and A__B__ and 

show results. 
c. Comment on variation of the standard deviation errors (if any) in previous results. 
d. Check dimensional attributes and tolerances for the job provided. 
e. Comment on why a sphere has been chosen for the tip. 
f. What is the material for probe tip and why is it chosen? 
g. Why is it better to use a bigger diameter tip for measurement? 
h. What is the principle of slide-guide mechanism for all the three machine axes? 

Precautions: 

! Never touch the granite base on the machine for accuracy issues. 

! Do not touch the Axis slides, probe head/tip, and the guides. 

 

Calibration and Measurement procedures are detailed in 
ANNEXURE - I 
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ANNEXURE 1 

Description of Working Plane: 
There are 6 working plane in this machine such as, Z+,Z-,Y+,Y-,X+,X-. 
 
 

 

 
 
 
  
 
 
Note: Z- will be in opposite direction of Z+ plane. Similarly, X- & Y+ will be in opposite directions of X+ and 
Y- planes, respectively.  
 
Orientation Concept of Probe: 
When probe is rotated about X-axis it is then called as angle A and when probe is rotated about Z-axis, then it is 
called as angle B. 
Tesastar-p is the probe used in this machine. This probe can rotate in two directions viz A & B 
 

A0B0:- Angle A=0, and Angle B=0    
 

                                                                                             

                 A0B0 position of probe                                      A90B90 position of probe 
 
 

Convention: 
When rotation of probe is in CCW manner w.r.t. axis of rotation than it is considered positive else negative. 
 

Range of angles: 
 

Angle A: Probe can rotate from +90 to -115 about X-axis. 
Angle B: Probe can rotate from +180 to -180 about Z- axis 
 
 
   

Machine Table 

Artifact 

X+ 
working 
plane 

Y – Working Plane 

Z+ working plane 
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Description of Remote Control Unit: 

Emergency 
Stop 

Joystick (To control the 
machine movement) 

To run machine 
at lower speed To activate joystick 

To lock the 
movement of 
respective axes 

To delete previous 
hits 

To run machine 
automatically 

To enter the feature 
into software 

To disconnect servo 
control between 
machine and software 

To start servo 
control 
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Description of Graphics Display Window: 

CAD view 
Edit 
window 
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Probe Calibration: 
 

Probe calibration is important while creating a new Part Program 
 

1. Open the PCDMIS program by double clicking on the Online desktop icon. Otherwise PCDMIS can also be 
opened by selecting the Start>All Programs > PCDMIS for Window>Online.  

 
 

2. Select a Probe file. Recently used probe file will be shown. If new tip is going to be attached, select Probe 
File, otherwise select already displayed one.  

 
 

3. At this stage the system will prompt for homing. First make sure to clear the work table for safe movement 
of the probe. Select OK to permit the machine to go in home position.     

 
 

4. Following message will appear if the remote is not set in Auto mode. Click the AUTO button on remote 
control. 

 
 
 
 

5. Once machine comes to homing position, place the Qualification Sphere in the middle of the work table. 
The Open File dialog box will appear on the screen. If you have previously created a part program, you can 
load it from this dialog. 
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6. Since you are creating a new part program, select the Cancel button to close the dialog box. 
 

7. Go to File>New> New Part Program box. In the Part Name box, type Filename. If the Interface shows 
OFFLINE it means machine is not connected. 

 
 

 

8. Select the Measurement Units option for the measurement. 
 

As soon as you have created a new part program, PCDMIS will open the main user interface and then 
immediately open the Probe Utilities dialog box for you to load a probe. 
 

The Probe Utilities dialog box, can also be accessed by selecting Insert > Hardware Definition > Probe, 
allows you to define a new probe. When you first create a new part program, PCDMIS automatically brings up 
this dialog box. 
 

 
 

 
 

Probe Utilities dialog box 
 
9. In the Probe File box, type the already created Part Name as the name of the probe file. Later, when you 
create other part programs, your probes will be available in this dialog box for selection. 
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10. Select the statement: No Probe defined. 
 

The Probe Description area of the Probe Utilities dialog box allows you to define the probe, extensions and 
tip (s) that will be used in the part program. The Probe Description dropdown list displays the available probe 
options in alphabetical order. 
 

Select your probe using the Probe Description combo box: 

 
 

11. Select the line "Empty Connection #1" and continue to select the necessary probe parts until your probe is 
built.  

 Select: TESASTAR-M (selected by default)   (Probe Head) 
 Select: TESA-TMA                           (Probe Connector)  
 Select: TESASTAR-P                                 (Probe) 
 Select: Tip-(dia.) by (Length) mm                               (Stylus) 
** For example, if we are using 4 mm diameter probe tip having 30 mm stylus length then select: 

Tip4BY30MM (Stylus)   
 

 
 

Verify that the defined Probe File is displayed in Probe Window; else select from the drop down menu. 
 

13. Click Add Angles… from probe utilities window to select probe angle. Fill up the required probe angles 
against the box A Angle and B Angle, then click Add Angle > OK. 
 

 
Active Tip List 

 
 

PCDMIS describes a probe according to the following criteria: 
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Tip ID # 
This is the permanent number that PCDMIS assigns to a tip when it is loaded into memory. 
Tip Rotation 
This field displays the rotation of the tip in the vertical (A) and horizontal (B) direction 
Tip Type 
This field displays the probe type (BALL, DISK, TAPER, SHANK, OPTICAL). 
XYZ Nominal 
These values describe the location of the tip. This location is in relation to the bottom of the Z rail. 
IJK Direction 
These values describe the direction of the probe tip. This vector goes from the center of the probe tip towards 
the Z rail. 
Diameter and Thickness 
These values describe the diameter of the tip and the thickness of SHANK and DISK probes. PCDMIS defines 
these values when the probe is loaded.  
Calibration Date and Time 
These boxes indicate the most recent date and time the probe tip was calibrated. If a new tip is created without 
being calibrated, PCDMIS will display NEW for the date and time values. If an old probe tip is loaded and the 
date and time information is unavailable, PCDMIS will display UNKNOWN for the values. Only probe tips that 
are actually calibrated have their time and date values updated. 
Only one tip may be edited at a time. 
Non-calibrated Tip 
An asterisk (*) identifies any non calibrated tips. 
The Edit window command line for a sample tip would read: 
TIP/T1A0B0, SHANKIJK=0, 0, 1, ANGLE=0 
 

 
 

Non calibrated Tips Marked with Asterisks (*) 
 

14. Select *A0B0 unmarked probe feature and click Measure from Probe Utilities window. Measure Probe 
window will appear 

 

Select Man+DCC option when 
calibrating the first position of probe 
(i.e. A0B0). Select DCC+DCC for 
subsequent angles. 

Default Mode: The machine decides on its 
own the number of levels. 
The equator is considered to be at 0 degree 
start angle and the poles at 90 degree when the 
tip moves vertically down. 

Add Tool: Specify the 
specification of the 
qualification tool  
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Once you define a new tool, it will appear in the List of Available Tools dropdown list located in the Measure 
Probe dialog box. 
At least one probe tip must be defined in the Active Tip List before measuring a tool. 

 

16.  After setting Tool type, click OK and click Measure in the Measure Probe window, the following 
warning message will pop up: 
 

 
 

If the qualification tool has been moved from the previous position select Yes, otherwise No. 
On selecting Yes a final confirmation window for calibration will come up: 
 

 
 

17. Once we click OK the execution window will begin for the manual hit on approximately top of the 
Qualification Sphere as cited below: 
 

 
 

By Clicking Add Tool… following window will 
appear 
 
 Fill the boxes as shown in the window. 
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Press SLOW button on REMOTE CONTROL UNIT and take one hit manually on the top of the sphere and 
press RTN TO SCREEN. Press AUTO on the remote control as command AUTO MODE REQUIRED 
appears at the bottom of the display window. 
 

18. Calibration Results: Coming back to Probe Utilities Window click Results and check the standard 
deviation value. Assure the Std. Dev value lies within 0.008 mm, otherwise stop the machine and go for 
tightening the extension-stylus-tip joints. 
 

 
Click OK. 
To calibrate rest of the angles (if any), change Man+DCC to DCC+DCC in the Measure Probe window to 
repeat the above procedure. 
 

19. Once calibration is over, remove the Qualification Sphere and place the job on the work table 
  
Creating Features (Manual mode): Preamble: Manual+DCC 

 
a. Create a Point ( ) 
 Click on Measured Point icon. Take a hit on the surface (where point is to be made) > RTN TO SCREEN 
from remote control 
 

 
 
b. Create a Line ( ) 
Click on icon Measured Line >Take two points on a surface > Press RTN TO SCREEN. 
 

 
 
 
 

Line1 

Point 1 
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c. Create a Plane ( ) 
Click on Measured Plane icon > Take three points such that it covers the entire plane> RTN TO SCREEN. - 
 

 
 

d. Creating a Circle( ) 
Click on Measured Circle icon>Take three hits on the inner periphery of circle (in CW or CCW manner)> 
Press RTN TO SCREEN. 
 

 
e. Create a Cylinder ( ) 
Click on Measured Cylinder icon> Take 3 hits on top inner periphery of cylinder> take 3 hits at the approx. 
bottom periphery (inner) of cylinder (use CW or CCW manner for both type of hits) > Press RTN TO 
SCREEN. 
 

 
 

Plane 1

Circle 1 

Cylinder1 
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f. Create a Cone ( ) 
Click on Measured Cone icon> Take 3 hits on top inner periphery of cone> take 3 hits at the approx. bottom of 
the periphery (inner) of cone (use CW or CCW manner for both type of hits) > Press RTN TO SCREEN. 
 

 
g. Create a Sphere ( ) 
Click on Measured Sphere icon> Take 3 hits on the equatorial plane > Take 1 hit at approx. top >Press RTN 
TO SCREEN 
 

 
 

h. Create a Round Slot ( ) 
Click Measured Round Slot >Take 3 hits on inner periphery of semicircle> Take 3 hits on inner periphery of 
the opposite semicircle > Press RTN TO SCREEN. 
 

 
 
 
 
 
 
 
 
  

Cone 1 

Round 
slot 1 

Sphere 1 
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